Filtering E-mail for Spam: Macintosh
# Table of Contents

**Introduction** .................................................................................................................. 1

Objectives .................................................................................................................................. 1

**Filtering E-mail for Spam** .................................................................................................. 2

What Is Spam? .......................................................................................................................... 2
What Is UT Doing About Spam? ............................................................................................... 2
What Can You Do About Spam? ............................................................................................... 2
What Are Filters and Rules? ...................................................................................................... 3
Other Filtering Options ............................................................................................................. 3
Limitations of Rules and Filters ............................................................................................... 3
Viewing Full Headers .................................................................................................................. 4
Filtering for Spam ...................................................................................................................... 4

**Creating Rules in Microsoft Outlook 2001** ...................................................................... 5

*Viewing the Full Headers* ........................................................................................................ 5
*Creating a Rule* ......................................................................................................................... 5
*Editing or Deleting a Rule* ...................................................................................................... 5

**Creating Filters in Eudora Pro** ............................................................................................ 6

*Viewing the Full Headers* ........................................................................................................ 6
*Creating a Filter* ......................................................................................................................... 6
*Deleting a Filter* ......................................................................................................................... 6

**Creating Filters in Outlook Express or Entourage** ............................................................... 7

*Viewing the Full Headers* ........................................................................................................ 7
*Creating a Rule* ......................................................................................................................... 7
*Using the Junk Mail Filter* ......................................................................................................... 8

**Creating Rules in OSX Mail** ............................................................................................... 8

*Viewing the Full Headers* ........................................................................................................ 8
*Creating a Rule* ......................................................................................................................... 8
*Deleting a Rule* ......................................................................................................................... 8

**Creating Filters in Yahoo! Mail** .......................................................................................... 9

**Creating Filters in Hotmail** .................................................................................................. 9
Introduction

In this course, *Filtering E-Mail for Spam*, you will learn how to identify the senders of unwanted e-mail by viewing the full headers and how to filter these messages to another folder so they won’t arrive in your inbox. This handout contains specific instructions for Microsoft Outlook, Microsoft Outlook Express, Eudora, Yahoo! Mail, and Hotmail.

Objectives

The learning objectives of this workshop are:

1. To learn about spam and how it can affect your computer and network.
2. To understand filters, their uses and limitations.
3. To learn how to view headers and create filters or rules in Microsoft Outlook 2001, Microsoft Outlook Express, Microsoft Entourage, Eudora Pro, Mac OS X Mail, Yahoo! Mail, and Hotmail.
Filtering E-mail for Spam

What Is Spam?
Spam is unsolicited e-mail that crowds inboxes with unwanted and objectionable materials and hinders e-mail communication. Spammers abuse the use of e-mail messages as a direct marketing tool, sending sometimes thousands of unwanted messages each day.

Spam has never been more pervasive, and it is no longer merely an annoyance; it has begun to impact the performance of e-mail systems and networks.

What Is UT Doing About Spam?
The University’s Information Technology Services (ITS) department investigates anti-spam solutions for the major resources it manages. ITS evaluates commercial tools made by private companies and, if they are found helpful, offers them to the University community.

ITS also monitors the mail server’s system performance. When an excess of incoming messages is received, ITS blocks communication from the offensive, external sites that overload and crash the UMBS (mail.utexas.edu) mail service.

What Can You Do About Spam?
While spam is an unavoidable part of having an e-mail account, there are ways to reduce the amount you receive.

The following best practices will help you manage unwanted e-mail.

- **Create filters and rules** to screen unwanted mail using the instructions in this workbook.

- **Learn how to view the full headers in spam messages** to make filters and rules more effective and to enable ITS Help Desk staff to better assist you.

- **Avoid the “unsubscribe” feature included in spam messages.** Most spam includes instructions on how to "remove yourself from the list.” More often than not, these removal instructions do not work. Instead, when you click on the link to unsubscribe, you are verifying that you have a valid e-mail address and spammers will then permanently add you to their list or sell your address to others.

- **Do not reply to spam messages.** Responding lets spammers know they have found a valid e-mail address and they will continue to use it.

- **Install anti-virus software and update it often.** Current students, faculty, and staff can download anti-virus software from the BevoWare site. [http://www.utexas.edu/its/bevoware/](http://www.utexas.edu/its/bevoware/)

- **Be careful where you share your personal information online.** Be wary of filling in address, phone number, or e-mail information on non-secure sites. Some users create “junk” e-mail accounts with a free service to use on Web forms so their real e-mail address doesn’t receive large amounts of spam.

- **Report the problem to the spammer’s provider.**
• Report spammers to the ITS Information Security Office (ISO). When junk mail originates outside the University, ITS has little control. However, if the offending e-mail violates UT policies, the ISO will investigate the report and take appropriate action. Repeated incidents involving offensive e-mail may be harassment. If you feel you are being harassed, write abuse@utexas.edu. If you feel threatened, immediately call UT Police at 471-4441.

• Contact the University’s ITS Help Desk for additional help. http://www.utexas.edu/its/help/

• Always abide by the University’s Responsible Use Policy. http://www.utexas.edu/its/policies/responsible.html
  Specifically, you must not:
  * Threaten violence or vandalism against the site or user that sent you spam.
  * Hack into the site.
  * Mail-bomb, ping-storm, SYN-flood, or otherwise attack the site or user.

What Are Filters and Rules?
Filters, called Rules in Outlook and Outlook Express, are tools within e-mail programs that use specific criteria to identify incoming messages as spam. Filters can then transfer messages detected as spam to a specified folder—such as Junk Mail, Trash, or Deleted Items—before they reach your inbox.

The process for creating filters and rules differs slightly in each program but the basic concept is the same. Once you understand generally how to create a filter, you can apply that understanding to any e-mail program that you use in the future.

Other Filtering Options
In addition to creating specific filters and rules, your e-mail program can filter messages on a broader level. For example, Microsoft Outlook can use a default list of terms to filter suspected junk e-mail. This list of terms is stored within the Outlook folder as filters.txt. Other e-mail programs also offer pre-defined terms to filter suspected junk or adult content mail.

Limitations of Rules and Filters
Successfully filtering e-mail requires constant attention. Filters are rarely completely effective because junk mail senders change constantly. Thus, you must constantly update rules and filters.

As a rule or filter may sometimes target personal mail that is not spam, it is best to filter spam into a folder that you can periodically check to make sure you are not losing essential mail. Also, you must frequently empty your junk mail folder as mailbox space is limited and exceeding your limit could cause new incoming mail to bounce.
**Viewing Full Headers**

Filtering using the sender’s e-mail address is an effective method if the address is correct. Often spam is sent from fake, or “spoofed,” addresses, so it is ineffective to filter based on the address listed in the From: line. However, you can learn the real address of the sender by viewing the full headers.

The full header of an e-mail displays additional information about the sender and the route an e-mail takes before arriving in your inbox. Filters can be more effective if you block a sender’s complete address as displayed in the full header. Instructions on how to view full headers are included within the procedures below for the e-mail programs discussed in this workbook.

**Filtering for Spam**

Filtering for spam can be a challenge since spam messages usually come from many different senders, including senders who use fake e-mail addresses or send from multiple addresses. Below are several strategies that can increase the effectiveness of your filters:

- Filter for offensive words that might appear in a spam message, but not in a message you would want to keep.
- Filter for URLs that appear in spam.
- Use the e-mail address from the full header view to create a filter or rule.
Creating Rules in Microsoft Outlook 2001

Viewing the Full Headers

To view full headers in Microsoft Outlook 2001:
1. Open a message.
2. On the File menu, click Properties.
3. Click the Headers tab.
4. Look for lines that begin with Received: — they detail the path the e-mail took to reach your inbox. Received: lines are listed in chronological order, with the most recent mail server listed at the top. The Received: line at the bottom of the list contains the address of the original server that sent the mail. It also lists an authenticated timestamp that shows when the message was sent.
5. On the Received: line at the bottom of the list, click-and-drag to highlight the server address that appears in parentheses, then press COMMAND()+C to copy the text.

For example, if you see this line:
Received: from [192.168.2.2] (user-12345.cable.mindspring.com [192.168.1.300])

Highlight and copy the text marked in bold below:
Received: from [192.168.2.2] (user-12345.cable.mindspring.com [192.168.1.300])

6. Close the window and use this server address to create a rule, as described below.

Note: Do not copy any server address that contains “utexas.edu.” This will filter out legitimate mail.

Creating a Rule

To create a rule in Microsoft Outlook 2001:
1. On the Tools menu, click Rules.
2. Click Add Rule.
3. In the When message arrives that meets the following conditions area, enter the filter criteria. You can enter the sender’s e-mail address in the From box or enter specific words to filter for in the Subject and Message Body boxes.
4. In the Perform these actions area, select the type of actions you want performed on the filtered messages. You can select the Move to check box and specify the folder where messages should be transferred.
5. Click OK.

Editing or Deleting a Rule

1. On the Tools menu, click Rules.
2. Highlight the rule you want to edit or delete.
3. To edit the rule, click on Edit Rule.
4. To delete the rule, click Delete Rule.
Creating Filters in Eudora Pro

Eudora Pro has filters that allow you to automatically sort your incoming and outgoing mail. The simplest filters sort incoming messages into specified mailboxes. For example, each time you check your mail, you can have Eudora automatically transfer all incoming messages that contain “get rich quick” to the Trash folder.

Viewing the Full Headers

To view full headers in Eudora Pro:
• Open the message and click the Blah Blah Blah icon in the message window.

Creating a Filter

To create a Filter in Eudora Pro:
1. Open an incoming message containing the e-mail address or other information you want to filter.
2. On the Special menu, click Make Filter.
3. In the Make Filter dialog box, select conditions from the Match menu. Select the Incoming, Outgoing, or Manual check boxes.
   a. Select From contains if you want to filter future messages sent by the sender of this message.
   b. Select Any recipient contains if you want to filter messages that are sent to any recipients of this message.
   c. Select Subject contains if you would like to filter all future messages with a certain subject.
4. In the Action menu, select where you would like to direct filtered messages. You have three options:
   a. Select Transfer to a new mailbox and enter the name of the new folder in the text box.
   b. Select Transfer to existing and select the name of an existing folder from the drop down menu.
   c. Select Delete message (Transfer to Trash) to filter messages to the trash.
5. Click Create Filter.

The new filter is added at the bottom of your filter list in the Filters window (on the Tools menu, select Filters). When the filters are activated, every message is matched against all filters. If the message meets a filter’s criteria, Eudora transfers the message to the specified folder.

Deleting a Filter

To delete a filter in Eudora Pro:
1. On the Tools menu, select Filters.
2. Highlight the filter in the filters list.
3. Click Remove.
Creating Filters in Outlook Express or Entourage

Outlook Express is a free e-mail program that comes with the Windows operating system and should not be confused with Microsoft Outlook.

Microsoft Entourage is an e-mail and personal information manager for the Macintosh. Steps for creating rules in Entourage are identical to those for Outlook Express on the Macintosh.

Viewing the Full Headers

To view complete header information in Outlook Express:
1. From an open message, on the View menu, click Source.
2. Look for lines near the top that begin with Received: — they detail the path the e-mail took to reach your inbox. Received: lines are listed in chronological order, with the most recent mail server listed first. The last Received: line in the list contains the address of the original server that sent the mail. It also lists an authenticated timestamp that shows when the message was sent.
3. On the last Received: line in the list, click-and-drag to highlight the server address that appears in parentheses, then press COMMAND+C to copy the text.

For example, if you see this line:
Received: from [192.168.2.2] (user-12345.cable.mindspring.com [192.168.1.300])

Highlight and copy the text marked in bold below:
Received: from [192.168.2.2] (user-12345.cable.mindspring.com [192.168.1.300])

4. Use this server address to create a filter in your third-party spam tool.

Note: Do not block any server address that contains “utexas.edu.” This will filter out legitimate mail.

Creating a Rule

To create a rule in Outlook Express or Entourage:
1. On the Tools menu, click Rules.
2. Click New.
3. In the Rule name box, enter the name for the rule.
4. In the If criteria section, on the All Messages drop down menu, select Specific Header.
5. In the Contains box, enter the sender’s address copied from the full header.
6. In the Then section, select an action from the drop down menu. To move the message to a specific folder, select Move message from this drop down menu, then select your preferred folder from the second drop down menu that appears.
7. You can select more than one action, and add or delete actions.
8. When you are done, select the Enabled check box and click OK.
9. Rules are applied to all future incoming messages. To apply a rule to the messages currently in your inbox, on the Message menu, click Apply Rule, and select the rule to apply.
Using the Junk Mail Filter

Outlook Express can also use pre-set criteria to filter Junk Mail.

To filter for junk mail:
1. On the Tools menu, click Junk Mail Filter. Select the Sensitivity from a range of low to high. Outlook Express adjusts criteria depending on the level of Sensitivity selected. If you choose a higher sensitivity level, more e-mail will be filtered.
2. Click OK. You will be asked whether to apply the Junk Mail Filter settings to the messages in your Inbox. Click Apply or Don’t Apply.

Note: Messages from contacts in your Address Book are never assigned to the Junk category. You can also prevent other domains or addresses from being filtered by listing them in the Do not apply to messages from these domains box.

Creating Rules in OSX Mail

All rules created in OS X Mail will run automatically when a new message is received. You can also run a rule on a message already in your Inbox. To do this, highlight the message and on the Message menu, click Apply rules to Selection.

Viewing the Full Headers

To view the full headers in OS X Mail:
1. Highlight the message.
2. On the Message menu, click Show All Headers. Full headers will appear in the message.
3. Find the From information and copy all the information between <>. Use this address in a rule to delete messages from this particular sender.

Creating a Rule

To create a rule that automatically transfers messages from a particular sender to a specified folder:
1. Highlight the message.
2. On the Mail menu, click Preferences.
3. Click the Rules icon.
4. Click Create Rule.
5. In the Description box, enter a name for the rule.
6. In the Criteria section, select From and Contains from the drop down menu.
7. Enter the sender’s e-mail address from the full header in the box to the right of Contains.
8. In the Action section, select the Transfer to Mailbox: check box.
9. Select the folder that messages should be transferred to from the drop down menu.

Deleting a Rule

To delete a rule in OS X mail:
1. On the Mail menu, click Preferences.
2. Click the Rules icon.
3. Highlight the rule in the list, then click Remove.
Creating Filters in Yahoo! Mail

To create filters in Yahoo e-mail:
1. Click on Options.
2. Select the Block Addresses option to keep certain addresses from reaching your account.
3. Select the Filters options to sort incoming messages for specific conditions. Conditions can be set to match a message’s full header or just to match the To, Cc, and Subject lines. You can also create filters based on words within the body text of a message. Yahoo! Mail also uses a Spammguard to automatically forward bulk mail to a Bulk Mail folder.

Creating Filters in Hotmail

To filter junk mail in Hotmail:
1. Click Options.
2. On the Mail Handling menu, click Junk Mail Filter. In the Junk Mail Filter window, select your preferred options.

Hotmail also provides Block Sender and Custom Filters options that you can use to create filters for specific e-mail addresses and other criteria.